Service does not start with Error 503 in the UI with "Waiting for changelog lock..." in BE logs
This error is related to a database lock that happens each time the Allure TestOps service starts. If the application gets interrupted when it is appying changes to the database structure it does not release the database lock and during the next start it cannot get the access to the database.
Whet. it happens you will be obvserving in the BE logs the following messages:
You can see logs by running logs collection command.
Cause
This issue can be caused by unexpected service restart or shuitdown.
Solution
Stop Allure TestOps service
Connect to the database uisng psql tool
psql -h db.host -U db-username testops-db-name
Get the content of the table containing locks data
select * from databasechangeloglock;
Delete the lock preventing a service to start
update databasechangeloglock set locked=false, lockgranted=null, lockedby=null where id=1;
Start the service again.